当前位置首页 > Debian知识

HDU-1076-AnEasyTask(Debian下水题測试.....)

阅读次数:241 次  来源:admin  发布时间:

Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)

Total Submission(s): 17062 Accepted Submission(s): 10902

Problem Description Ignatius was born in a leap year, so he want to know when he could hold his birthday party. Can you tell him?

Given a positive integers Y which indicate the start year, and a positive integer N, your task is to tell the Nth leap year from year Y.

Note: if year Y is a leap year, then the 1st leap year is year Y.

Input The input contains several test cases. The first line of the input is a single integer T which is the number of test cases. T test cases follow.

Each test case contains two positive integers Y and N(1<=N<=10000).

Output For each test case, you should output the Nth leap year from year Y.

Sample Input

3
2005 25
1855 12
2004 10000

Sample Output

2108
1904
43236


Hint
We call year Y a leap year only if (Y%4==0 && Y%100!=0) or Y%400==0.

 

Author Ignatius.L

Recommend We have carefully selected several similar problems for you: 1021 1097 1061 1032 1170

题目的意思非常easy:

就是让你求出从Y開始的年份第N个闰年......甚至不用考虑时间复杂度,强行AC!

主要是Debian下命令行不熟悉,费了不少时间......

#include<iostream>
#include<cstdio>
using namespace std;
int main()
{
    int t,Y,N;
    scanf("%d",&t);
    while(t--)
    {
        scanf("%d%d",&Y,&N);
        while(1)
        {
            if((Y%4==0&&Y%100!=0)||(Y%400==0))
            {
                N--;
            }
            if(N==0)
                break;
            Y++;
        }
        printf("%d\n",Y);
    }
    return 0;
}
上一篇:Apache+Tomcat
下一篇:问题排查利器:Linux原生跟踪工具Ftrace必知必会