当前位置首页 > Apache知识

Anincompatibleversion[1.1.33]oftheApacheTomcatNativelibraryisins

阅读次数:107 次  来源:admin  发布时间:

问题:

Anincompatibleversion[1.1.33]oftheApacheTomcatNativelibraryisinstalled,whileTomcatrequiresversion[1.2.14]

解决方法:

下载文件tomcat-native-1.2.14-win32-bin.zi

网址:http://archive.apache.org/dist/tomcat/tomcat-connectors/native/1.2.14/binaries/

Anincompatibleversion[1.1.33]oftheApacheTomcatNativelibraryisinstalled,whileTomcatrequiresversion[1.2.14]

解压后其中有32位和64位的 tcnative-1.dll 文件,根据自己的电脑选择相应位的文件。

Anincompatibleversion[1.1.33]oftheApacheTomcatNativelibraryisinstalled,whileTomcatrequiresversion[1.2.14]

一共看到三种建议:

1.将文件拷贝到C:\Windows\System32

2.放在tomcat的bin路径下

3.放在tomcat的bin和机器上安装的jdk的bin路径下

本人采用的是第二种方法,直接拷贝到tomcat的bin目录下

上一篇:XP下配置IIS后本地正常,其它机器无法显示页面
下一篇:Linux开机自启应用&开机执行脚本&监听端口应用挂掉了执行启动脚本