当前位置首页 > Apache知识

CoreException:CouldnotgetthevalueforparametercompilerIdforplugin

阅读次数:275 次  来源:admin  发布时间:

今天遇到一个奇怪的问题, 之前写好的代码, 更换环境后, 重新搭建的nexus, maven私服总是报错, 各种clean/update都不管用

CoreException:CouldnotgetthevalueforparametercompilerIdforpluginexecutiondefault-compile:PluginResolutionException:Pluginorg.apache.maven.plugins:maven-compiler-plugin:3.1

原来是没写版本号, 后来加上3.1版本, 还是报错, 查看本地仓库里面, 这个jar包已经下载下来了

去nexus控制台找这个jar, 发现有个更高的版本

CoreException:CouldnotgetthevalueforparametercompilerIdforpluginexecutiondefault-compile:PluginResolutionException:Pluginorg.apache.maven.plugins:maven-compiler-plugin:3.1

在项目里面改成更高的3.6版本之后, 经过一系列的clean, update之后, 终于不报错了!

CoreException:CouldnotgetthevalueforparametercompilerIdforpluginexecutiondefault-compile:PluginResolutionException:Pluginorg.apache.maven.plugins:maven-compiler-plugin:3.1

总结: 可能你的maven-compiler版本不够高, 更换高版本jar包试试

友情赞助

如果您喜欢此文,感觉对您工作有帮助,预期领导会给您涨工资,不妨小额赞助一下,让我有动力继续努力。

赞助方式:打开支付宝App,使用“扫一扫”付款,付款码见下图,别忘了付款留言哦!

CoreException:CouldnotgetthevalueforparametercompilerIdforpluginexecutiondefault-compile:PluginResolutionException:Pluginorg.apache.maven.plugins:maven-compiler-plugin:3.1

或使用微信, 不用加好友就能付款

CoreException:CouldnotgetthevalueforparametercompilerIdforpluginexecutiondefault-compile:PluginResolutionException:Pluginorg.apache.maven.plugins:maven-compiler-plugin:3.1

上一篇:64位系统下IIS7配置
下一篇:python在CentOS7中的安装